忍者ブログ

X5-452's Blog

Windows(32,64bit)用 x264_L-SMASH, L-SMASH, L-SMASH-Works, MP4Box, libav, ffmpeg, x262, xvp8, Libpack, ニコニコ関連, バイナリ&ライブラリ&BuildScriptの配布

[PR]

×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。


GCC 4.5.3に落ち着いた

 GCC4.6.xだと
warning: ・・・・・ [-Wunused-but-set-variable]
warning: ・・・・・ [-Wunused-value]
↑が多々出るのでGCC4.5.3に落ち着きました。
やはりGCC4.6.xは爆弾抱えてるのね。

GCCの気になるオプションを試してみた。
-ftree-loop-linear
-freorder-blocks-and-partition
-fwhole-program
 
ライブラリbuildで使うとErrorが出るものがある。
※ ライブラリbuildでのオプションは程々に・・・。

ffmpeg, x264のbuildで使うと
気持ち早くなったような気がした

無闇にオプション付け危険を犯す?より、程々にオプション付けた方が良いと感じた。
PR

コメント

NAME
TITLE
MAIL (非公開)
URL
EMOJI
Vodafone絵文字 i-mode絵文字 Ezweb絵文字
COMMENT
PASS (コメント編集に必須です)
SECRET
管理人のみ閲覧できます
 

トラックバック

TrackbackURL

  

カレンダー

08 2017/09 10
S M T W T F S
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30

フリーエリア

最新コメント

[01/19 mogmog]
[01/18 mogmog]
[12/20 mok]
[12/19 NONAME]
[11/11 k]
[10/20 vocho]
[10/10   ]

最新トラックバック

プロフィール

HN:
Sada_Maru
性別:
非公開

バーコード

ブログ内検索

最古記事

P R

カウンター

アクセス解析

忍者アナライズ

Copyright ©  -- X5-452's Blog --  All Rights Reserved

Design by CriCri / Material by 妙の宴 / powered by NINJA TOOLS / 忍者ブログ / [PR]